Changes between Version 20 and Version 21 of CompilingCloudyOSX

Show
Ignore:
Timestamp:
08/11/17 21:55:53 (9 days ago)
Author:
gary
Comment:

macOS works with gcc v6

Legend:

Unmodified
Added
Removed
Modified
  • CompilingCloudyOSX

    v20 v21  
    1717We recommended using homebrew to install gcc.  Versions of Cloudy after 13.03 have been modified to work with LLVM. 
    1818 
    19 There currently is an incompatibility when installing both gcc and LLVM, as described in [https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71767 this bug report].  For now, it is better to use LLVM from Apple and not 
    20 install the homebrew gcc.  Problems with LLVM can arise if you install homebrew gcc and have it on your path. 
     19~~There currently is an incompatibility when installing both gcc and LLVM, as described in [https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71767 this bug report].  For now, it is better to use LLVM from Apple and not 
     20install the homebrew gcc.  Problems with LLVM can arise if you install homebrew gcc and have it on your path.~~ 
    2121 
    22 These problems may be fixed someday.  For now, we leave the instructions for homebrew here, even though we do not recommend using it. 
     22~~These problems may be fixed someday.  For now, we leave the instructions for homebrew here, even though we do not recommend using it.~~  
     23 
     24== Mid 2017 update == 
     25 
     26I installed Homebrew GCC 6.4.0 and built on macOS 10.12.6 / current Xcode without warnings.  The LLVM lldb debugger seemed to work with the gcc executable.   
    2327 
    2428-------------